【Ubuntuの初期設定】VirtualBox、デュアルブートなど

2週間ほど前にパソコンを入れ替えたものの、思うようにいかず苦労しましたのでここに記録します。
ちなみに私はパソコンのシステム知識なく、Ubuntu歴 1年のペーペーです。
 

新しいパソコンでやりたかったこと

  • VirtualBox環境下でWindowsやMacのテスト利用
  • 容量の大きいPC環境下でプログラミング
  • 今までどおりの画像編集や動画編集など

 

はまって解決できたこと

VirtualBoxのインストール

普通にUbuntu16.04LTS をセットアップして、Ubuntu Software からVirtualBoxをインストール。
エラーが出て起動できない。
いろいろ調べまくって、いろいろ作業してみた。
結果、カーネルやヘッダーなどシステム的なところまで変更し、エラーが多発、起動も遅くなった。

やったこと

Ubuntu16.04 に以下の内容を実行
  • VirtualBox 5.0.4 debファイル起動、失敗
    sudo apt-get remove –purge virtualbox-5.0 で削除
  • VirtualBox 5.0.40 debファイル起動、失敗
  • VirtualBox 5.1.26 debファイルの起動、失敗
  • ターミナルから sudo apt install virtualbox-qt 失敗

Ubuntu14.04.5 LTS、 Lubuntu でも上記と同じパターンを実行、すべて失敗。
Mint アプリセンターから VirtualBox インストールできたものの、起動時にエラー。

【MintにVirtualBoxをインストールした際の参考ページ】
https://www.pcsteps.com/184-install-virtualbox-linux-mint-ubuntu/

結局どれもだめで、ダメ元でPC起動時に F2 を押して、Boostのセキュリティーを DISABLE(無効)に変更。
すると Ubuntu16.04 で アプリセンターから VirtualBox をインストールできました。
その後、再起動時に Boost セキュリティーを ENABLE(有効)にすると、起動しませんでした。
結果、Boostのセキュリティーを外して、Ubuntu 16.04 LTS に VirtualBox 5.0.40(Ubuntu Software経由)をインストール。
 
 

VirtualBoxへのWindows10のインストール

なぜか Microsoft 公式ページからダウンロードしたWIndows10の iso ファイルではVirtualBoxがisoファイルを読み込んでくれません。
Windowsのロゴマークが画面に出たままで、インストールのステップに進まないのです。

【ダメだったWindows10のisoファイル】 Win10_1703_Japanese_x64.iso
【VirtualBoxのバージョン】 VirtualBox 5.0.40

前のPCで使用していた古いバージョンの iso ファイルを使ってみると読み込みました。
おそらく VirtualBox 側との相性があるのでしょうか?
 
【読み込んだisoファイル】 Win10_1607_Japanese_x64.iso
 
尚、本過程においてUSBを使ってisoファイルをコピペしたりしましたが、大容量のファイルをUSBでUbuntuPCに読み込む場合、専用ソフトが必要です。
【参考記事】 http://yaplog.jp/squirrel_cage/archive/678
 
上記と同じ設定で Mac OS Sierra のインストールもできました。
Ubuntu 16.04 LTS に VirtualBox 5.0.40(Ubuntu Software経由)
【Mac OS Sierra インストール参考動画】 https://www.youtube.com/watch?v=pVc6rxk3OUM

やはり5年前のPCに比べると激速で、VirtualBox内でもストレスをほとんど感じません。
パソコンを新しくしてよかったと感じました。

 

 

デュアルブート

今回OSなしのPCを買ってUbuntuをインストールしました。
ハードディスクを分割し、複数のOS(ディストリビューション)をインストールできることがわかったのですが、あとでハードディスクの領域分割を行うと起動が遅くなったり、エラーの原因に。
私の場合は、メインハードディスクに Ubuntu、サブハードを2分割し、Mintをインストールしましたが、これでは最初にインストールした Ubuntu を起動した時、Boostの設定がOS側とBIOS側で異なるようで、起動に3分ほど時間がかかりました。
 
起動時間がわかるコマンド  systemd-analyze blame  を実行しても起動アプリの所要時間がわかるだけで、BIOS側とOS側のBoostエラーはわかりませんでした。
コマンド  sudo blkid  を実行するとハードディスクの割当を確認できます。
これが Ubuntu インストール時に確認できるハードディスクの割当と違いました。
 
 
この問題は、もう一度メインハードディスクにUbuntuをインストールすることで解決できました。
(インストール作業の中で、ディスク内をすべて削除し、Ubuntuをインストール)

 

Google Chrome

Chromeの公式ページから .deb ファイルをダウンロードしただけでは Chrome は起動しませんでした。
エラー無しで実行できた方法は、
  1. Chromium のインストール(Ubuntu Softwareから)
  2. Chrome公式ページから .debファイルをダウンロードして、Chrome の .deb ファイルの実行
  3.  .deb ファイルのあるフォルダで「右クリック→端末で開く」
  4. 端末に入力するコード  sudo dpkg -i Chromeのファイル名.deb
すると libappindicator1 が足りないとのこと
 
sudo apt-get install libappindicator1
 
もう一度 sudo dpkg -i Chromeのファイル名.deb でインストールが完了します。
あとはChromeにログインするとブックマークやパスワードなど自動で同期してくれます。

 

日本語の文字入力

デフォルトAppのテキストエディタは問題ないのですが、Visual Studio Code や BoostNoteで日本語を入力すると、変換候補が入力中の文字の上にラップして表示。
これでは今何をタイプしているのかわかりません。
いろいろ調べた結果、 Mozc の設定で解決できました。

 

画面左上の Ubuntuロゴをクリックして mozc を入力し、「Mozcの設定」を起動
タブ欄の「サジェスト」をクリックして、すべてのチェックを外します。
すると文字を入力しても変換候補が自動で表示されずにスムーズに文字入力できます。

またUbuntuを使っていて、困ったこと・解決できたことがあれば情報アップしていきたいと思います。

時間があれば BIOSやBoostのことなど学びたいものです。。。

 

Leave a Reply

will not be published

wp-puzzle.com logo